Welcome to the Shining Force Central Forums!
SFC Forums Index Shining Forums Shining Force
Register for your free forum account now or Login to remove this advert.

Sega Genesis Collection (switch version) sound glitch

Has anyone else had this come up?

Discussion about the original classic Genesis/Mega Drive game. Posts about the GBA remake belong in the forum below.

Sega Genesis Collection (switch version) sound glitch

Postby ShiningForceKaya » Tue Jan 08 2019 5:46pm

I got the Sega Genesis Collection for nintendo switch and already I am having sound glitches galore. Can't play it more than an half hour before the sound starts peeling apart or doubling and half plays normal and the other half lags, its real weird. It also sounds quite grainy. It started after say 5 hours of level grinding on the first battle, then got pretty bad and regular around chapter 2.

I had similar issues on the sega smash pack 2 edition for Pc after say 3 years of playing it hard core , but then again I did play it so much that there is permanent laser burn where shining force data is on the disc..... so yeah. :(

This version is for switch and is on a card not disc, so whats going on? and is there a fix?
Verily I say unto you all:Arise and shine forth, that thy light may be a standard for the nations;
D&C 115:5

Check out the Shining force group on DA: http://legacyofshiningforce.deviantart.com/
Verily I say unto you all:Arise and shine forth, that thy light may be a standard for the nations;
D&C 115:5

Check out the Shining force group on DA: http://legacyofshiningforce.deviantart.com/
 
Posts: 66
Joined: Tue Feb 01 2011 2:00am

Re: Sega Genesis Collection (switch version) sound glitch

Postby unclesporky » Mon Jan 14 2019 4:58pm

I own this on Switch and I haven't noticed issues like that. However one thing I do regularly is use the saving and loading savestate options, as well as closing the game entirely from the main Switch menu and opening it again. I'm not sure if I've played this game for 5 hours straight with no interruptions yet. But you could try closing and opening the game.

I will say in general the controls are laggy and the sound does sound slightly off, but nothing like what you describe. My version is digital. You could also try updating it, press + on the game at the main menu and choose software update.
unclesporky

Newbie
Newbie
 
Posts: 1
Joined: Sun Dec 16 2018 4:39am


Return to Shining Force

Who is online

Users viewing this topic: No registered users and 0 guests